Issues with PGP
Incident Report for InternetNZ
Resolved
This incident has been resolved.
Posted Nov 27, 2020 - 09:17 NZDT
Investigating
We are currently investigating this issue.
Posted Nov 27, 2020 - 08:07 NZDT
This incident affected: .nz OpenPGP Keyserver.