IRS Production Contact Object Lifecycle issue
Incident Report for InternetNZ
Resolved
No issues have appeared in the last 24 hours, we are satisfied the fix was successful.

Please contact registry@internetnz.net.nz for any further issues
Posted Feb 08, 2023 - 15:10 NZDT
Monitoring
The fix has been applied to production at 15:36 NZDT and we are currently processing the backlog of contact object lifecycle changes.

The sub job that caused the issue is processing records correctly without throwing errors.

We will monitor for the next 24 Hours.
Posted Feb 07, 2023 - 16:34 NZDT
Update
Contact object lifecycle changes continue to be paused in IRS Production

Our vendor has supplied a fix for the issue, this has been deployed into internal testing environments and is undergoing validation, no issues have been encountered so far.

We plan to deploy this fix to IRS Production on Tuesday 7th February at 15:30 NZDT, this will be a hazard only window as no externally facing services are impacted by the change.

Any variation to this plan will be posted here.

Please contact registry@internetnz.net.nz if you have any issues.
Posted Feb 03, 2023 - 16:16 NZDT
Update
We are continuing to work on a fix for this issue.
Posted Jan 30, 2023 - 14:54 NZDT
Identified
An issue has been identified with Contact Lifecycle operations, which have been paused as a result, all other IRS functions should be operating normally, we have escalated with our vendor, and will continue to monitor.

DNS Zone updates were not affected as previously stated.
Posted Jan 30, 2023 - 12:45 NZDT
Investigating
One of the backend applications in the IRS is experiencing errors due to a possible mismatch between database schema and what the application expects. We are working urgently with the software vendor to resolve the issue. Until the issue is resolved, updates and new zones in the IRS will not take effect in DNS zones or WHOIS output.
Posted Jan 30, 2023 - 11:47 NZDT
This incident affected: IRS Production (EPP, TBR, Portal, WHOIS).