pgp.net.nz
Incident Report for InternetNZ
Resolved
This incident has been resolved.
Posted Jul 01, 2020 - 16:44 NZST
Update
This incident has been resolved
Posted Jul 01, 2020 - 16:42 NZST
Update
We are continuing to investigate this issue.
Posted Jul 01, 2020 - 16:40 NZST
Investigating
We are investigating an issue with the SKS software, the service is currently unavailable
Posted Jul 01, 2020 - 11:41 NZST
This incident affected: .nz OpenPGP Keyserver.